CRAN Package Check Results for Package dynwrap

Last updated on 2020-01-24 23:50:30 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.1.4 17.83 261.65 279.48 OK
r-devel-linux-x86_64-debian-gcc 1.1.4 15.58 195.28 210.86 OK
r-devel-linux-x86_64-fedora-clang 1.1.4 331.32 NOTE
r-devel-linux-x86_64-fedora-gcc 1.1.4 316.37 NOTE
r-devel-windows-ix86+x86_64 1.1.4 58.00 297.00 355.00 OK
r-devel-windows-ix86+x86_64-gcc8 1.1.4 61.00 380.00 441.00 OK
r-patched-linux-x86_64 1.1.4 14.80 229.65 244.45 OK
r-patched-solaris-x86 1.1.4 440.30 NOTE
r-release-linux-x86_64 1.1.4 14.73 225.18 239.91 OK
r-release-windows-ix86+x86_64 1.1.4 31.00 264.00 295.00 OK
r-release-osx-x86_64 1.1.4 ERROR
r-oldrel-windows-ix86+x86_64 1.1.4 22.00 245.00 267.00 OK
r-oldrel-osx-x86_64 1.1.4 NOTE

Check Details

Version: 1.1.4
Check: package dependencies
Result: NOTE
    Imports includes 22 non-default packages.
    Importing from so many packages makes the package vulnerable to any of
    them becoming unavailable. Move as many as possible to Suggests and
    use conditionally.
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.1.4
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘hdf5r’ ‘jsonlite’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 1.1.4
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘dyndimred’
Flavor: r-release-osx-x86_64

Version: 1.1.4
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘dyndimred’
Flavor: r-release-osx-x86_64

Version: 1.1.4
Check: examples
Result: ERROR
    Running examples in ‘dynwrap-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: add_dimred
    > ### Title: Add or create a dimensionality reduction
    > ### Aliases: add_dimred is_wrapper_with_dimred get_dimred
    > ### Keywords: adapt_trajectory
    >
    > ### ** Examples
    >
    > dataset <- example_dataset
    > dataset <- add_dimred(
    + dataset,
    + dyndimred::dimred_landmark_mds
    + )
    Error in loadNamespace(name) : there is no package called ‘dyndimred’
    Calls: add_dimred ... loadNamespace -> withRestarts -> withOneRestart -> doWithOneRestart
    Execution halted
Flavor: r-release-osx-x86_64

Version: 1.1.4
Check: tests
Result: ERROR
     Running ‘testthat.R’ [53s/51s]
    Running the tests in ‘tests/testthat.R’ failed.
    Last 13 lines of output:
     4. base::asNamespace(ns)
     5. base::getNamespace(ns)
     6. base::loadNamespace(name)
     7. base::withRestarts(stop(cond), retry_loadNamespace = function() NULL)
     8. base:::withOneRestart(expr, restarts[[1L]])
     9. base:::doWithOneRestart(return(expr), restart)
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     [ OK: 918 | SKIPPED: 1 | WARNINGS: 0 | FAILED: 3 ]
     1. Error: (unknown) (@test-method_infer_trajectory.R#3)
     2. Error: Testing add_dimred including calculation of dimred (@test-wrap_add_dimred.R#110)
     3. Error: Test get_dimred (@test-wrap_add_dimred.R#278)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-release-osx-x86_64