CRAN Package Check Results for Package protti

Last updated on 2022-01-18 01:52:09 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.1 17.82 241.74 259.56 OK
r-devel-linux-x86_64-debian-gcc 0.2.1 13.97 176.39 190.36 OK
r-devel-linux-x86_64-fedora-clang 0.2.1 239.82 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.1 222.60 OK
r-devel-windows-x86_64-new-UL 0.2.1 117.00 282.00 399.00 OK
r-devel-windows-x86_64-new-TK 0.2.1 ERROR
r-patched-linux-x86_64 0.2.1 16.16 232.08 248.24 OK
r-release-linux-x86_64 0.2.1 OK
r-release-macos-arm64 0.2.1 NOTE
r-release-macos-x86_64 0.2.1 OK
r-release-windows-ix86+x86_64 0.2.1 6.00 9.00 15.00 ERROR
r-oldrel-macos-x86_64 0.2.0 NOTE
r-oldrel-windows-ix86+x86_64 0.2.1 7.00 9.00 16.00 ERROR

Check Details

Version: 0.2.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘proDA’
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-macos-arm64

Version: 0.2.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'drc'
Flavor: r-devel-windows-x86_64-new-TK

Version: 0.2.1
Check: tests
Result: ERROR
     Running 'testthat.R'
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(protti)
     Welcome to protti version 0.2.1!
    
     Have fun analysing your data!
     >
     > test_check("protti")
     ══ Failed tests ════════════════════════════════════════════════════════════════
     ── Error (test-workflow.R:563:1): (code run outside of `test_that()`) ──────────
     Error: Package "drc" is needed for this function to work. Please install it.
     Backtrace:
     █
     1. └─protti::fit_drc_4p(...) test-workflow.R:563:0
    
     [ FAIL 1 | WARN 0 | SKIP 0 | PASS 103 ]
     Error: Test failures
     Execution halted
Flavor: r-devel-windows-x86_64-new-TK

Version: 0.2.1
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavors: r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 0.2.0
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: 'proDA', 'STRINGdb'
Flavor: r-oldrel-macos-x86_64